Detail information about FFCMS 3 features and benefits

Application, widgets and themes store from ffcms and community developers

Find developer to solve your tasks or start freelance on ffcms system now

Download latest FFCMS 3 version and get info about installation methods

Migration to php >= 7.1 was initialized

News 127
Poster for: migration to php >= 7.1 was initialized

Greatings, ffcms user! We start to move our project to modern php 7.1 syntax level. The previous FFCMS version are builded with support of deprecated now php 5.5, 5.6 and ending of lifecycle 7.0.

The current php development status make a new trand of application development and in 2018 there is no place for old and deprecated version of php interprier. FFCMS as open source software will follow current trands and move our core to newest php 7.1 syntax features.

With new 3.1.0 realise system requirement will updated to:

  • PHP 7.1.3 or newest (7.2)
  • Mysql 5.5, Mariadb 5.5, Postgres 9.6 or newest 

Also the fundamental core packages will be updated to:

  • Symfony http foundation: 3.4 (LTS)
  • Swift mailer: 6.0 
  • Dot access data: 1.1
  • PHP fast cache: 6.0
  • HybridAuth: 2.10

Also, all intermediate changes will be included in major update! Keep watching!

0
Comments

CMS online demo
New comments